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Chapter 1: Introduction to
FileDrive Client
Software
tact

to
Overview
This chapter describes this manual and the conventions used in it. It also gives
some background on the FileDrive family of applications, describes how to con
Receipt.com for support and upgrades, gives a brief overview of FileDrive
Windows Client and describes how to install and uninstall FileDrive Windows
Client.

About This Guide
This guide describes the FileDrive Windows Client application. It describes how
set up the Client and how to use it to send, receive and view files. This guide is
written for users who are familiar with Windows NT or 95/98.

Conventions used in this Guide
The following conventions are used in this guide:
FileDrive Windows Client User Guide - 7
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Text Formatting
Paths and links, (host names and world-wide web addresses), are printed in italics, for examp

www.wheredoIcomefrom.org

Thewhatamacallitlink

File and Directory names are bold, for examplelost/manuscripts/need.txt

Sample interactive sections that show command line input and system output are printed in co
The prompt is displayed as the pound sign (#), or asfdx> . Commands that are user supplied, are
printed in bold courier, for example:

Where is the FileDrive license located? (enter the pathname)

# home/users/hereitis

Some commands can include optional arguments that are displayed in brackets, ([] ). Arguments
listed as generic names are meant to be replaced with your input and are italicized. For examp
commandls is used to display the contents of a directory which is the working directory or a
specified remote directory. It is documented this way:

ls [remote-directory]

Generic Names
FileDrive Server and/or FileDrive Client are sometimes referred to as FileDrive.

FileDrive Client software for Windows 95/98 and Windows NT is sometimes referred to as the
Win32 Client or the Windows Client.

Actions
Clicking the right mouse button is called right-clicking. A menu that appears when you right cl
is called the right mouse menu. Instructions for selecting an item from the right-mouse menu
documented like this:

• Right-click on the F.

• From the right-mouse menu, select Manager.

Menus and sub-menus are represented with the side carat, (>). Where appropriate, menu item
underlined and capitalized as they appear on the screen. For example, to start FileDrive you
8 - FileDrive Windows Client User Guide
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on the Start menu and select the Programs sub-menu and from that sub-menu you select the
FileDrive sub-menu and from that sub-menu select FileDrive. This is documented like this:

From the Start menu select Programs > FileDrive > FileDrive

The FileDrive Family
FileDrive is a family of secure file transfer software products for critical data interchange and
automated document processing. FileDrive products provide high performance file transfer
capabilities and facilitate large-volume data movement. They are designed for the distribution
collection of commercially valuable files over the Internet. FileDrive products are fully compati
with FTP and HTTP standards.

In addition to integrating state-of-the-art security standards such as Secure Socket Layer (SS
digital certificates (X.509), FileDrive contains a sophisticated access control system, and
EnGuard™ security auditing software that automatically warns of potential security issues.

FileDrive is client/server software, made up of the FileDrive Server and the FileDrive Client.
FileDrive Server allows you to set up and maintain a secure file transfer site. FileDrive Client t
your PC or UNIX workstation into a powerful, secure and reliable download and upload mana
FileDrive Client runs both as a stand-alone application and as a web browser plug-in. FileDriv
scalable making it an ideal building block for industrial-strength extranet applications.

FileDrive also guarantees Extranet data delivery and data integrity while protecting corporate
bandwidth. Auto Restart automatically re-establishes broken connections and resumes trans
where they left off until the data is delivered, regardless of network outages or computer crash

FileDrive’s functionality can be easily extended through ActiveAgents™. ActiveAgents are
transactional software agents that can initiate events based on file tranfers and can also feed
information into back-end applications such as databases, enterprise scheduling software an
network printing operations. ActiveAgents also make it easy to add third-party functionality to
FileDrive, such as virus scanning, file format conversion, or additional security mechanisms a
required.

FileDrive Clients
FileDrive Clients are available for Windows NT/98/95, UNIX and MVS OS/390. You can also u
a standard browser as a client.
FileDrive Windows Client User Guide - 9
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FileDrive Windows Client
FileDrive Client software for Windows 95 and Windows NT provides high performance, reliab
and secure file transfer of critical business documents from the FileDrive Server over your intr
business extranet or the Internet. FileDrive Client connects with the FileDrive Server and safe
transmits large documents, graphics, software, and a range of other file types to and from a re
network site.

The FileDrive Windows Client has all of the standard features of regular FTP and more. The
Windows Client offers the following additional features to a typical file transfer:

• FileDrive’s patent-pending Auto Restart technology provides unparalleled reliability whe
transferring large files (100Mb - 4Gb) over unreliable network connections, dial-up
connections, overloaded servers or the Internet. Auto Restart allows you to restart a file
transfer if the connection is interrupted or the transfer is terminated for some reason.

• FTP, HTTP or HTTPS file transfers.

• SSL.

• Security through encryption of all communications.

• Supports X.509 certificates for authentication of client and server identities.

• Supports Tunnel Mode, which is a firewall friendly mode that allows you to connect
securely through a firewall or proxy server.

• MD5 checksums of local and remote files.

• Supports mirrored server locations.

• Provides highly reliable, high performance and secure transfer of large files over the Inte
or private network when accessing a FileDrive Server.

• Client-side APIs allow you to embed FileDrive capabilities into your own applications.
10 - FileDrive Windows Client User Guide
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FileDrive Features and Benefits
Features Benefits

Supercharged File Transfer

• Secure and reliable downloading and
uploading of very large files.

• Adds high performance file transfer
capabilities to your Web browser.

• Secure server.

• Complete system customability and
tensibility through ActiveAgents
APIs.

• Compatible with FTP and HTTP
protocols.

• Allows customers to design, deploy,
and access a new generation of
network-accessible business services,
online software distribution systems,
digital rights management systems
and business-to-business commerce.

Rapid Resume

• Automatically restarts transfers if
network connection fails.

• Restart transfers from where the last
transfer left off.

• Allows you to pause and resume file
transfers.

• Schedules file uploads and
downloads for unattended transfer in
one time or recurring fashions.

• Automatically rolls-over to alternate
FileDrive mirrored servers.

• Keeps a log of file tranfers.

• Reliable high-performance transfer of
large documents over unreliable
network connections.

• Provides guaranteed “Fed-like”
delivery of any number or size of files
(documents, graphics, software, etc.),
along with flexibility on scheduling
automatic file uploads and
downloads.

• Automatically accesses alternate
mirrored FileDrive servers in case of
a failed connection.
FileDrive Windows Client User Guide - 11
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Built-In Full System Security

• Secure Sockets Layer (SSL)
encryption, client and server.

• Support for X.509 digital certificates.

• Name and password support.

• FileDrive server has extensive
security features.

• Provides a range of security options
for ensuring that files, IDs and
passwords are transferred securely.

• FileDrive Server provides a complete
suite of access controls and security
monitoring systems to ensure server
security.

ActiveAgents

• Client and server-side Application
Programming Interfaces (API).

• Automatically generate content
processing based on client file
requests.

• Automatic post-processing of
transferred files.

• Allows the functionality of FileDrive
to be easily extended by defining
processes that take place on files
coming or going from the client or
server. (For example, automatically
send notices on database changes,
virus scan incoming data before
accepted, serial number stamping,
preload a file into a database).

Easy to use

• Drag-and-drop interface.

• Client runs as a standalone
application and as a Netscape
Navigator protocol handler.

• Makes the process of transferring
files easy and intuitive.

• Seamlessly supercharges the file
transfer functionality of your
Netscape Navigator browser.

Features Benefits
12 - FileDrive Windows Client User Guide
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Install FileDrive Windows Client
FileDrive Win32 Client is distributed on a CD. To install, (or upgrade), the application:

• Insert the CD in your CD-ROM drive.

• Double-click on the Install icon.

• Follow the instructions.

Note: You must restart your system after you install FileDrive.

Cross-Platform

• Windows 95/NT.

• UNIX command-line client.

• Netscape Navigator support (versions
2.0 and up).

• Microsoft Internet Explorer 4.0.

• Microsoft Internet Explorer 3.0 via
drag-and-drop links from your
browser to FileDrive.

Note: Internet Explorer has a bug that
prevents third parties from
directly enhancing its file
transfer capabilities. Microsoft
has fixed this bug for Internet
Explorer 4.0.

• Allows customers to deploy
FileDrive on the industry-leading
hardware and software platforms
across the organization.

Based on Industry Standards

• TCP/IP

• FTP

• HTTP

• SSL

• HTML

• Allows seamless integration of
FileDrive into your intranet or
Extranet.

Features Benefits
FileDrive Windows Client User Guide - 13
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Uninstall FileDrive Windows Client
Once FileDrive Client has been installed, you can uninstall it. If you installed FileDrive Client i
the default directory:

• From theStart menu select Programs > FileDrive > Uninstall FileDrive.

Note: If you installed FileDrive in any other folders, substitute the appropriate folders.

FileDrive is uninstalled.
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Overview
This chapter describes how to start FileDrive Windows Client. It also describes
interface and controls and how to access the various screens.

Start FileDrive Windows Client
To start the Client, use the Start Menu.

Note: If you have the preference set to launch FileDrive at startup, FileDrive
may be running.

If you installed FileDrive Client in the default directory:

• From theStart menu select Programs > FileDrive > FileDrive.

Note: If you installed FileDrive in any other folders, substitute the
appropriate folders.
FileDrive Windows Client User Guide - 15
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A small F will be displayed in the lower right hand corner of your screen.

Exit FileDrive Windows Client
To exit the Client:

• Right-mouse click on the F.

• From the right-mouse menu, select Exit.

User Interface
The controls for FileDrive Client are accessed through the buttons and menus in several diffe
GUI, (graphical user interface), screens. They are the Explore, Progress, Manager and Prefe
screens.

Manager Screen
The main screen for accessing the Client controls is the Manager screen. To access the Man
screen:

• Double-click on the F icon in the lower right-hand corner of the screen

OR

• Right-mouse click on the F.

• From the right-mouse menu, select Manager.
16 - FileDrive Windows Client User Guide
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The Manager screen displays.

Manager Toolbar
The FileDrive Manager toolbar, at the top of the Manager screen, has nine buttons to simplify
sending and receiving files. Please refer to the diagram below to identify each button with its n
and function.
FileDrive Windows Client User Guide - 17
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1. Transfer Now—Starts transfer of any selected entries.

2. Schedule—Opens a window so you can set a specific time for a transfer to occur.

3. Change Destination—Opens a Save As window so you can set the download director
the selected entries and if desired change the name.

4. Info (Information)—Opens the transfer log screen for the selected items.

5. Delete—Deletes any selected files from the transfer list.

6. Explore—Opens the Profiles - New Explore screen to allow you to search for files or
create profiles.

7. Progress—Displays the Progress screen, which gives you the status of any files bein
transferred.

8. Preferences—Displays the Preferences screen to configure FileDrive for your
environment and other preferred settings.

9. Help—Launches the online help system for FileDrive Client.

View Options
The Manager displays one of four different views, depending on what is selected in the first d
down list. Use the drop down list to select one of these options:

• Files to Receive—The Manager displays a list of files that are being received or schedul
be received.
18 - FileDrive Windows Client User Guide
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• Files to Send—The Manager displays a list of files that are being sent or scheduled to b
sent.

• Files Received—The Manager displays a list of files that have been received.

• Files Sent—The Manager displays a list of files that have been sent.

Menu Options
The following options are available from the menus in the Manager screen.

File Menu
The following options are available in the File menu of the Manager screen.

• Explore—Opens an Explore Profiles window which allows you to add, modify, and dele
user profiles for file transfers.

• Open URL—Opens a window in which you can enter a fully qualified “http”, “ftp”, “gxp”,
“ftpu”, or “gxpu” URL. For example to send files type:

ftpu://user:password@host/pathname

A Send Files window displays for you to select the files to send.

To explore a site, enter a pathname that ends in/ . An Explore screen displays.

• Send Files—Opens a window in which you can enter a server address (such as
ftp.YourCompany.comor 205.115.164.123), the port number (for FTP the default is 21), the
user name (leave blank for anonymous), the password (leave blank for anonymous), an
path name on the server to send the files. This window is similar to entering an “ftpu” lin

• Receive Files—Opens a window in which you can enter a server address (such as
ftp.YourCompany.comor 205.115.164.123), the port number (for FTP the default is 21), the
user name (leave blank for anonymous), the password (leave blank for anonymous), an
path name on the server to send the files. This window is similar to entering an “ftpu” lin

• Transfer Now—Starts transfer of any selected entries.

• Schedule—Opens a window so you can set a specific time for a transfer to occur.

• Change Location—Opens a Save As window so you can set the download directory for
selected entries and if desired change the name.

• Information—Opens the transfer log screen for the selected items.

• Remove—Deletes any selected files from the transfer list.

• Close—Closes the Manager screen.

• Exit—Exits FileDrive.
FileDrive Windows Client User Guide - 19
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Edit Menu
The Edit menu of the Manager screen contains the standard Windows controls for Undo, Cut,
Copy, Paste, Select All and Invert Selection. You can also access the Preferences screen.

To access the preferences screen from the Edit menu, select Edit > Preferences.

View Menu
The following options are available in the View menu of the Manager screen.

• Toolbar—Toggles the display of the Manager toolbar.

• Status Bar—Toggles the display of the Status bar at the bottom of the screen.

• Progress Window—Displays the Progress screen.

Help Menu
The Help menu of the Manager screen contains access to the online help for FileDrive. To find
information about FileDrive, for example the version number, select Help > About FileDrive.

Profiles - New Explore Screen
Use the Profiles - New Explore screen to create, modify, copy or delete connection profiles or
explore a location to find files to transfer. You can explore any local drive or any remote site th
has a profile. You can also use this screen to create a desktop shortcut to a profile.

Profiles
A profile is information about a connection that is stored. This is what you use to connect to a
server with the client. Profiles make it easy to connect to common servers without having to re
information. Profiles can be selected when sending or receiving files, but need to be created i
Profiles - New Explore screen.

Access Profiles - New Explore Screen
To access the Profiles - New Explore screen:

• Right-mouse click on the F.
20 - FileDrive Windows Client User Guide



Profiles - New Explore Screen
• From the right-mouse menu, select Explore.

OR

• From the Manager screen, select File > Explore.

OR

• Click the Explore button, in the toolbar.

The Profiles - New Explore screen displays.

Explore Profile
To Explore a connection or local drive:

1. Select a drive or profile from the window of the Profiles - New Explore screen.

2. Click Explore.
FileDrive Windows Client User Guide - 21
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An Explore screen displays.

The Explore screen displays the contents of the drive or folder you selected.

OR

If you selected a connection profile, FileDrive attempts to connect to the directory specified in
profile.
22 - FileDrive Windows Client User Guide



Profiles - New Explore Screen

the

les.
If your password is expired, the Change Password screen displays.

3. Enter your old password and a new password.

4. Click OK.

If the connection is successful, the contents of the folder specified in the Startup Path field of
profile are displayed.

5. Click on folders to explore further or use the Explorer toolbar to upload or download fi
FileDrive Windows Client User Guide - 23
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Explore Toolbar
The Explore toolbar, at the top of the Explore screen, has sixteen buttons. Please refer to the
diagram below to identify each button with its name and function.

1. Up one level—Changes the current view up one folder or directory level.

2. New Explore—Opens a new Explore screen.

3. Explore From Here—Opens a new Explore screen with the current folder as the star
point.

4. Refresh—Refreshes the current view.

5. Download To—Opens a Download To window, which downloads the selected file to a
location that you specify in the window.

6. Download—Downloads the selected file to the default location.

7. Upload—Opens an Upload screen to select a file. The file is uploaded to the location
is selected in the Explore screen.

8. Copy—Copies the selection to the clipboard.

9. Paste—Pastes the clipboard contents.

10. Delete—Deletes the selected file or folder.

11. Properties—Displays properties of files and folders.

12. Large Icons—Shows large icons.
24 - FileDrive Windows Client User Guide
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13. Small Icons—Shows small icons.

14. List—Shows a list of files and folders.

15. Details—Shows details of files and folders.

16. Manager—Switches to the Manger screen.

Transfer Files From Explore Screen
You can transfer files several ways from the Explore screen. You can use buttons in the toolba
can use the right-mouse menu or you can drag and drop.

Drag and Drop
You can drag and drop files to and from the Explore screen. You can do this to upload or down
files or folders.

You can drag and drop to and from:

• The desktop.

• The Manager screen.

• Another Explore screen.

• A Microsoft Explorer window.

Download
Other ways to download a file, from the Explore screen:

1. Explore to locate a file and if necessary click once on the file to select it.

2. Use the right-mouse menu to select download or download to.

OR

Click the download button, (the down-pointing arrow), in the Explore toolbar.
FileDrive Windows Client User Guide - 25
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If you select download, FileDrive attempts to download the selected file. If you select downloa
the Download To screen displays.

3. Use the Drives drop down list to locate the drive to which to download the file.

4. Use the Folders drop down list to locate the desired folder.

5. If desired, click Network to locate a drive on your network.

6. Click Cancel to abort the download.

7. Click OK to start the download.

FileDrive downloads the selected file.

Upload
Other ways to upload a file, from the Explore screen:

1. Explore to locate the directory or folder you want to upload a file into.

2. Select upload from the right-mouse menu.

OR
26 - FileDrive Windows Client User Guide
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Click the upload button, (the up-pointing arrow), in the Explore toolbar.

An Upload screen displays.

3. Use the Look in drop down to locate the file to be uploaded.

4. Click on the file to select it.

The file name displays in the File name field.

5. Click Open to start the upload.

The file is uploaded.

Add Profile
To create a connection profile, in the Profiles - New Explore screen:

1. Click Add.
FileDrive Windows Client User Guide - 27
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An Explore Profile screen displays.

The Explore Profile screen contains four pages; one for each connection type. The connection
are FTP, HTTP, HTTPS and Local Computer. The FTP, HTTP and HTTPS pages are identica
except the FTP page contains an option to login as an anonymous user.

2. Select the appropriate Tab for the connection type.

3. Enter information in the following fields:

For FTP, HTTP and HTTPS profiles:

• Host Address—Enter the address of the host to connect.

• Port—Enter a port. The default ports are already entered, but you can enter any
desired value.
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• Login—Enter your login name (if not anonymous).

• Anonymous—For anonymous logins, (FTP only), select this check box.

Note: The Login and Password fields fill in automatically.

• Password—Enter your password for connect.

• Startup Path—Enter the startup path on the server you are exploring.

• Download Path—This field displays any current default download path. Enter a p
or use the Browse button to find where you want to download files.

• Cache data between sessions—Select this option to have FileDrive cache data
between sessions.

• Profile Name—Enter a Profile name. This field automatically displays information
you enter into the Host Address and Login fields, but you can enter any desired n
FileDrive Windows Client User Guide - 29
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For Local Computer profiles:

• Path—Enter the desired local path, use the button to select a local path o

select the all drives option below.

• All drives on local machine—Select this option to include all drives.

• Profile Name—Enter a Profile name. This field automatically displays any
information entered in the Path field, but you can enter any desired name.

For all profiles:

4. Click OK.

Note: If you have not entered all the required information for a new profile, the OK button
is greyed out.
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The Profile name is displayed in the list of profiles in the Profiles - New Explore screen.

Modify Profile
To modify a connection profile:

1. Select a profile from the list of profiles in the Profiles - New Explore screen.

2. Click Modify.

3. Make the desired changes.

4. Click OK.

The profile is modified.

Duplicate Profile
To copy a connection profile:

1. Select a profile from the list of profiles in the Profiles - New Explore screen.

2. Click Duplicate.

A copy of the profile is created in the list of profiles in the Profiles - New Explore screen. A suf
is added that includes the copy number, for example the first copy of the profileNew Profile is
calledNew Profile-1.

Delete Profile
To delete a connection profile:

1. Select a profile from the list of profiles in the Profiles - New Explore screen.

2. Click Delete.

The profile is removed in the list of profiles in the Profiles - New Explore screen.
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Create Shortcut
To create a shortcut to a connection profile:

1. Select a profile from the list of profiles in the Profiles - New Explore screen.

2. Click Shortcut.

A shortcut to the selected profile is added to your desktop.

Exit Profiles - New Explore Screen
To exit the screen:

• Click Close.

OR

• Click the X in the upper right-hand corner of the screen.

Progress Screen
The Progress screen shows the status of any files that are waiting to be transferred and the pr
of files that are transferring. If a file is being transferred, you can pause it from this screen.

To access the Progress screen:

• Right-mouse click on the F.

• From the right-mouse menu, select Progress.

OR

• From the Manager screen, select View > Progress window.
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The Progress screen displays.

Progress Screen Options
The following options are available when a file is transferring. (If no file is transferring, the Pau
and Cancel buttons are greyed out).

• To pause a transfer, click Pause.

• To cancel a transfer, click Cancel.

• To access the Manager screen, click Manager.

Preferences Screen
Preferences allow you to create your own business and security standards for using FileDrive
Preference screen is where you set your preferences.

To access the Preferences screen:

• Right-mouse click on the F.

• From the right-mouse menu, select Preferences.

OR

• From the Manager screen, select Edit > Preferences.
FileDrive Windows Client User Guide - 33
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The Preferences screen displays.

Preference settings are contained on seven pages within the Preferences screen. Each page
at the top with its name. The pages are:

• General

• Transferring
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• Scheduling

• Security

• Proxy/Firewall

• Explore

• Entrust

Note: The Entrust Preferences screen is only displayed in the Entrust-ready client.

To display a page:

• Click the appropriate tab at the top of the Preferences screen.

To set preferences:

1. Use the tabs to switch pages.

2. Select any desired options.

3. Click Apply.

To cancel any changes you have made:

• Click Cancel.

To display the Help file:

• Click Help.
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General Preferences

The following options are available on the General page:

• Identification: Email address—Enter your email address. It is used as your password w
you log in as an anonymous user.
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• Prompt: Before deleting queued items—If this option is selected, you are prompted whe
you try to delete items that are waiting to be transferred.

• Navigator Integration: Intercept Navigator links—If this option is selected, FileDrive
launches when you go to an FTP site using Netscape Navigator.

• Startup: Launch FileDrive at system startup—Select one of the radio buttons to determi
you want the Client to start automatically at System Startup. Select Never, Only when it
are pending, or Always.

• Upgrade—FileDrive automatically checks for newer versions and upgrades automatical
you select the Automatically upgrade FileDrive option, enter how often you want to chec
the Check Server every days field. You can also click Check Now to check right away.

• Use PASV mode—If this option is selected, the Server provides the address and port fo
Client to connect to when transferring. If not checked, the Client is in PORT mode and
provides the address and port for the Server to connect to when transferring.

• Share connection between Explorer and Manager—If this option is selected the Client i
limited to one connection with the Server, (some Servers are set up to only allow one
connection per login). If this option is not selected, you can transfer a file while exploring
new connection is made to the Server so you can continue exploring while the transfer
occurs.

Note: The advantage of using this option, (if not required), is that transfers occur more
quickly since the overhead of re-login is eliminated. The disadvantage is that you ca
not explore while performing a transfer.
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Transfer Preferences

The following options are available on the Transferring page:

• Default Download location—Use the radio buttons to select whether you want the Clien
Ask for file location when saving files or to Automatically save files. If you choose to hav
FileDrive ask for a location, you are prompted each time you download a file. If you cho
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to automatically save, enter the path name or use the Browse button to locate the desire
folder.

• Transfer Mode—Use the radio buttons to select the transfer mode. Select binary, text o
select the Perform text mode transfers for files ending with: option. If you select the last
option, enter the file suffixes, (for example .html or .txt), separated by commas, in the fie
below. Files of types not specified are transferred in binary mode.

• Download files—Use the radio buttons to select whether to overwrite files on your syste
that have the same name as files that are downloading or to create new unique name fo
downloading file.

• Expand compressed files after downloading—Select this option to have the Client
decompress compressed files after download.

• Compress upload files using—Select this option to have the Client compress files that y
are sending. If you select this option, use the drop down menu to select a compression
application.

Note: We recommend using WinZip with FileDrive Client.

• Launch installer programs automatically—Select this option to have the Client start insta
programs that you download.
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Scheduling Preferences

The following options are available on the Scheduling page:

• Connection—Enter the number of times you want to retry a failed connection in the Ret
Transferred file field. Enter the number of minutes to wait between retries in the Delay
between retry field.
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• Enable Dial-up Networking—Select this option to use a dial-up account. If you select th
option, use the drop-down menu to select from your phone list entries, (that have been s
through your control panel). For Windows 95 and 98, your password must be specified in
dial-up login window.

• Schedule—Select this option to have the Schedule screen open before any transfer oc
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Security Preferences

The following options are available on the Security page:

• Enable Security— Select this option to have the Client negotiate to use the Server’s sec
system upon connection. Use the checkboxes below to set the desired level of security.
checkbox must be selected for Entrust.
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Note: If this option is selected, files will still transfer without security if the Server has no
security, unless you select the Use only secure connections option.

• Use only secure connections— Select this option to require encrypted, (SSL), connecti

• Always use firewall-friendly secure connections (tunnel mode)—Select this option to
require the Client to connect in tunnel mode.

• Prompt user when not recognizing the authority of a certificate— Select this option to ha
the Client warn you if a certificate is from an unknown source.

• Do not accept certificates with unrecognized authorities— Select this option to require
certificates from known sources, (present in your certificate file).

• Certificate file— Enter the pathname for a certificate file or use the Browse button to loc
a certificate file.

• Key file— Enter the pathname for a key file or use the Browse button to locate a key file

• Import authority certificate to storage—Click this button to import a certificate.
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Proxy/Firewall Preferences

The following options are available on the Proxy/Firewall page:

• Connect through a proxy server or a firewall—Select this option to configure the Client t
connect to other local network computers through a proxy server or through a firewall.
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• Proxy Settings—Enter the Proxy address the type of proxy you are using, FTP, HTTP, o
SOCKS, in the appropriate fields or to import the settings from your default browser, clic
the Import button.

For FTP or SOCKS servers that require a user name and password, click User and ente
user name and password.

• Proxy Exceptions—Enter any addresses for which you do not want to use a Proxy Serv
Use commas to separate multiple entries. Wildcards can be used in this field.

• FTP Firewall Type—For FTP firewalls, select the firewall type from the drop down menu
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Explorer Preferences

The following options are available on the Explorer page:

• Show Explore Profiles upon startup— Select this option to have the Client show the Exp
profiles. For more on profiles, seeProfileson page 20.
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• Automatically refresh current view—Select this option to have the Client automatically
refresh the current directory view. The Client connects to the current Server and update
view periodically based on the number of minutes entered in the minutes field.

• Cached Files—Enter a time period for the cache data to expire. To manually clear the c
click theClear All Cached Filesbutton. This section also lists the current number of cache
files, the amount of disk space used and the path of the cache.
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Entrust Preferences

The following options are available on the Entrust page:

• Enable Entrust supports— Select this option to have the Client use Entrust. You must
configure the rest of the options and login for Entrust to work.

Note: You must also select the Enable Security checkbox on the Security preferences p
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• Initialization file—Enter the location of your Entrust initialization (INI) file or click Browse
to locate it.

• Entrust Login—To enable Entrust for FileDrive you must enter the password for your
Entrust Profile file (EPF). Once you have logged in, the Entrust Login button is greyed o
To logout, click Entrust Logout.

To Login, click Entrust Login and a Login window displays.

• Profile Name—The profile name comes from the selected EPF file. To change the user n
use the drop down list or click Browse to locate another EPF file.

• Password—Enter the password for the EPF file.

• Work offline—Click in this checkbox to use Entrust in offline mode. In online mode (the
default) the Server certificate is verified by accessing the X500 directory. In offline mode
Server certificate is verified by accessing the Personal Address Book (PAB).

Note: Offline Mode is less secure since the certificate can not be checked for revocation
status, but may be useful if the Entrust PKI is not available or inaccessible.

• Click OK.
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Overview
This chapter describes different ways to transfer files and folders with FileDrive
Client. This chapter also describes how to schedule transfers.

Transferring files or folders can be sending or receiving, (downloading or
uploading). Scheduling of transfers is done to optimize resources and for regul
occurring transfers.

Send Files or Folders
Use FileDrive Windows Client to send, (or upload), large files, groups of files or
folders from your machine or network to another user over the Internet, quickly a
securely. To send files or folders use the File menu from the Manager screen o
Explore screen. You can also use your browser as a Client, (seeBrowser Clienton
page 64).

Send From Explore Screen
For instructions on how to send or upload files from the Explore screen, see
Transfer Files From Explore Screenon page 26.
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Send With File Menu
To send a file, from the Manager screen:

1. From the menu, select File > Send Files.

A Send Files window displays.

2. If desired, select a connection profile from the Connection Profiles drop down list.

The URL settings display the information from the selected profile. You can change any of the
following fields.

Note: If you change any of the fields, the profile name is not displayed in the Connection
Profiles field.

3. Use the Protocol list to select a transfer protocol; FTP, HTTP or HTTPS.

4. Enter the address of the server to which you would like to send files, in the Address fi
You may specify the exact IP address of the server using the standard dot format, for
example205.164.115.160.
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5. Enter the port on which the server is listening for a connection in the Port field.

Note: Keep in mind your transfer protocol.

6. Enter your user name in the User field or select the Anonymous checkbox. If the
Anonymous checkbox is selected, this field is greyed out with the word anonymous
displayed.

7. Enter your password in the Password field. If you selected the Anonymous checkbox
enter your user and domain name, for examplealien@wigglytreats.org.

8. Enter the path to where you want the file uploaded in the Path field. The path is the n
of the directory to which you want to upload files.

Note: The path names consist of a list of directories or folders separated by the “/”
character. Path names are generally case-sensitive.

If you specify a directory in the Send Files window, the path may be left empty to spec
the root path. On Windows 95 and NT, in DOS and in other programs, the “\” characte
used in the file paths. Do not use the “\” character in the path field to delimit path nam
The FTP standard is “/”.

Some examples of path names are as follows:

• /home/joe/

• /pub/test/samples

• /incoming

When specifying path names, remember that all path names are absolute path names
the root directory of the server. A path name that starts with “/” is not relative to the lo
directory. Because this window is a form-based way to specify a URL, and the URL
standard does not allow for relative path names from the login directory, relative path
names are not supported.

The entire URL for where the file is being sent is displayed next to the word URL.

9. Click Cancel to abort the cancel.

10. Click OK to start the transfer.
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After you click OK, the Send File(s) window displays where you select the files or folders to
transfer.

Add Files
To select a file to transfer:

1. Click Add Files.

An Open window displays.

2. Browse to locate a file in the Open window.

3. Double-click on the file, to add it to the list of files to send.

The file is added to the list of files to Send.
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Add Folders
To select a folder to transfer:

1. Click Add Folder.

An Open window displays.

2. Browse to locate a folder in the Open window.

3. Double-click on the folder, to add it to the list of files to send.

The folder is added to the list of files to Send.

Remove Files or Folders
1. Select a file or folder from the list of files to send.

2. Click Remove.

Toggle Move
To have the original file deleted after you upload it, enable the move feature. When move is
enabled, the word yes is displayed in the list of files to send, in the Move column.

To toggle the move feature:

• Select a File or folder.

• Click Toggle Move.

The move column displays yes or no depending on what was previously selected.

Start Transfer
To transfer the file either start the transfer or schedule it for another time.

To cancel the transfer:

• Click Cancel.
FileDrive Windows Client User Guide - 55



Chapter 3: Transfer Files

kly
plore
To schedule the upload for a different time:

• Click Schedule, (seeSchedule File Transferson page 59).

To start the transfer:

• Click Send.

The Client attempts to transfer any files for immediate transfer or queues any files that are
scheduled for later.

Receive Files or Folders
Use FileDrive Win32 Client to receive large files or folders from a server over the Internet, quic
and securely. To receive files or folders use the File menu from the Manager screen or the Ex
screen.

Receive With Explore Screen
For instructions on how to receive or download files from the Explore screen, seeTransfer Files
From Explore Screenon page 26.

Receive With Manager
To receive, (or download), a file, from the Manager screen:

1. From the menu, select File > Receive Files.
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A Receive Files window displays.

2. If desired, select a connection profile from the Connection Profiles drop down list.

The URL settings display the information from the selected profile. You can change any of the
following fields.

Note: If you change any of the fields, the Profile name is no longer displayed in the
Connection Profile field.

3. Use the Protocol drop down list to select a transfer protocol; FTP, HTTP or HTTPS.

4. Enter the address of the server from which you would like to download the file or files
the Address field. You may specify the exact IP address of the server using the stand
dot format, for example205.164.115.160.
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5. Enter the port on which the server is listening for a connection in the Port field.

Note: Keep in mind your transfer protocol.

6. Enter your user name in the User field or select the Anonymous checkbox. If the
Anonymous checkbox is selected, this field is greyed out with the word anonymous
displayed.

7. Enter your password in the Password field. If you selected the Anonymous checkbox
enter your user and domain name, for exampleImyoung@heart.org.

8. Enter the path from where the file is to be downloaded, in the Host Path field. The pa
the name of the directory where the file or files are located. Separate multiple entries
Returns, (not commas).

Note: The path name consists of a list of directories or folders separated by the “/”
character. Path names are generally case-sensitive.

If you specify a directory in the Receive Files window, the path may be left empty to
specify the root path. On Windows 95 and NT, in DOS and in other programs, the “\”
character is used in the file paths. Do not use the “\” character in the path field to delim
path names. The FTP standard is “/”.

Some examples of path names are as follows:

• /home/joe/

• /pub/test/

• /incoming

When specifying path names, remember that all path names are absolute path names
the root directory of the server. A path name that starts with “/” is not relative to the lo
directory. Because this window is a form-based way to specify a URL, and the URL
standard does not allow for relative path names from the login directory, relative path
names are not supported.

9. Enter the name of any files you want to download, in the File(s) field.

10. To delete the file from the server after you download it, select the Move checkbox.

11. To schedule the download, click Schedule, (seeSchedule File Transferson page 59).

The entire URL for any files being downloaded is displayed next to the word URL.

12. Click Cancel to abort the transfer.
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13. Click OK to start the transfer.

After you click OK, FileDrive attempts to download any files for immediate transfer or queues
any files for scheduled downloading.

Schedule File Transfers
FileDrive has a schedule feature that allows you to choose when and how often you want to tra
files. This is especially useful if you are moving large files or folders and want to perform the
transfer at the end of the business day when the server is not as busy.

To schedule any transfer:

• When you set up a file transfer, click on .

A Schedule window displays.
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In the scheduling window, you have the following choices for scheduling file transfers:

• Absolute

• Repeat

• Limit

You can also schedule multiple transfers for the same file or folder with the Advance Feature,
Advance Scheduleon page 63).

Setting an Absolute Time
An absolute transfer is a one-time transfer for which you set the day and time. To set an abso
transfer:

1. Click on the Date drop down list.

A calendar appears.

2. Click on the date you want to transfer the file. (Use the left and right pointing arrows t
display a different month).

3. To select the time you want the transfer to occur, click the arrow keys next to the Tim
field. To adjust hours, minutes or AM/PM, click on the hours, minutes or AM/PM and
then click the arrows to adjust the desired time.

4. Click Advance to schedule multiple transfers.

5. Click OK to schedule the transfer.

6. Click Cancel to abort the scheduling (not the transfer).

7. Click Now, to transfer right away.

Repeat Transfers
The Repeat feature allows you to set a transfer to occur on a periodic basis from a specific st
date and time. Set the period to be a number of minutes, hours, or days.

To use the Repeat schedule feature:

1. Click on the Repeat tab, in the Schedule window.
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The Repeat page displays.

2. Click on the Start Date drop down list, to select the start date.

A calendar appears.

3. Click on the date you want to transfer the file. (Use the left and right pointing arrows t
display a different month).

4. To select the time for the first transfer to occur, click the arrow keys next to the Start T
field. To adjust hours, minutes or AM/PM, click on the hours, minutes or AM/PM and
then click the arrows to adjust to the desired time.

5. Enter the repeat number in the Repeat every field.

6. Use the drop down list to select the period, either days, hours or minutes.

7. Click Advance to schedule multiple transfers.

8. Click OK to schedule the transfer.
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9. Click Cancel to abort the scheduling (not the transfer).

10. Click Now, to transfer right away.

Set Time Limits
The Limits feature lets you choose specific values such as the year, month, day, hour, minute

To use the Limit schedule feature:

1. Click on the Limit tab, in the Schedule window.

The Limit page displays.

2. Use the checkboxes to choose parameters to limit the transfer.

3. When you select a checkbox, use its arrows or drop down list to select the desired va

The Description box describes the limit you have selected.
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4. Click Advance to schedule multiple transfers.

5. Click OK to schedule the transfer.

6. Click Cancel to abort the scheduling (not the transfer).

7. Click Now, to transfer right away.

Advance Schedule
Use the Advance feature to schedule multiple transfers for the same file or folder. To use the
Advance feature:

1. At the bottom of the schedule window, click Advance.

The Advance window displays. Any scheduling that has been set up is displayed in the Sched
Event List.

2. Click Add to add a scheduled event.

A schedule window displays.

3. Schedule a transfer, (see previous sections for instructions).

4. Click OK.
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The Advance Schedule window displays with the new entry in the Scheduled Event List.

5. Click Edit to change a selected entry.

6. Click Delete to remove an entry from the Scheduled Event List.

7. Click OK when you are done.

8. Click Cancel to abort the scheduling of the transfer.

Browser Client
An alternate way to transfer files through a firewall, is to use a standard browser, like Netscap
Navigator or Microsoft Internet Explorer, to connect to a FileDrive Server.

To connect to a FileDrive Server with a browser:

1. Start your browser.

2. Enter the URL of the server in this format:

[scheme]://[hostname]: [port]

Scheme is FTP, HTTP or HTTPS. You can specify a directory as part of URL for the
hostname.

3. Login, if necessary.

4. Click on the FileDrive Logo, if necessary.
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Your home directory, (or the specified directory), on the server displays in the browser window

This page displays links to the directories and files to which you have access on the Server. A
top of the screen the folder or directory structure is displayed. Below the double lines, the con
of the selected file or directory is displayed.
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To navigate the site:

1. Click on the folder or directory links to display their contents.

2. Click on a file to display it.

Download or Delete File
To download a file from the Server:

1. Locate the file to download.

2. Click on the tools to the right of the file’s link.

A download window displays.

3. Click on the desired download or Delete option.

• Download as application/octet-stream to save to disk

A Save As window displays. Use the Save As window to name the file, (and if desired
select the location on your local system to save to) and click OK to save it.

• Download as text/plain to view text in the browser window.
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• Download as text/html to view an HTML file in the browser window.

• Delete to remove the file from the Server.

Upload a File
To upload a file to the Server, from the initial page:

1. Select the directory to which you want to upload a file.

2. Enter the pathname of the file in the Upload File field.

OR

Click Browse.

A File Upload window displays. Use the File Upload window to locate the desired file a
click OK to enter the file and pathname in the Upload File field.

Note: Use the Files of Type drop down list to select the appropriate file type.

3. Click Upload File.

The file is uploaded and the screen refreshes to display the file name in the list.
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